FAQ:MikroTik

Материал из Энциклопедия для сетевых администраторов
Перейти к: навигация, поиск

Блокирует торрент-траффик

Для маршрутизатора MikroTik

/ip firewall filter
add ac=drop ch=forward p2p=a
add ac=drop ch=forward in-int=e2 pr=udp cont=«d1:ad2:id20:» dst-port=1025-65535 packet-s=95-190
add ac=drop ch=forward in-int=e2 pr=tcp cont=«info_hash=» dst-port=2710,80

Какой порт использует WinBox

Консоль WinBox использует TCP порт 8291

router was rebooted without proper shutdown

Перевод: маршрутизатор был перезагружен без корректного завершения работы

Причины:

  • Сбой подачи питания
  • Аппаратная проблема
  • Перегруз по ресурсам

Реанимация MikroTik (RouterOS) с помощью NetInstall

1 (2).jpg

Для установки по сети не забудьте включить PXE сервер и проверьте, чтобы NetInstall не блокировался Вашим сетевым экраном и антивирусом. Роутер должен быть напрямую подключен к компьютеру, на которому запущена NetInstall, в крайнем случае через свич/хаб.

Загрузка прошивки по сети

Установка RouterOS на RouterBOARD 532 с ноутбука/ПК.

Требования Ноутбук/ПК должен иметь следующие порты и файлы:

  • порт Ethernet
  • serial-порт [не обязательно]
  • программу для serial-связи (например Hyper Terminal) [не обязательно]
  • файл(ы) .npk RouterOS (не .zip файл) той версии RouterOS, которую Вы собираетесь установить
  • приложение NetInstall (доступно для загрузки на официальном сайте)

Процесс соединения

  • Подключите RouterBOARD к хабу/свичу или напрямую к ноутбуку через Ethernet. Сетевой порт ноутбука должен быть настроен со статическим IP-адресом и маской подсети, к примеру 10.1.1.10/24 (т.е. IP 10.1.1.10 и mask 11111111 11111111 11111111 00000000 или то же самое в десятичном виде 255.255.255.0).
  • [не обязательно]. Подключите RouterBOARD к ноутбуку serial-кабелем и запустите serial-сессию между RouterBOARD и ноутбуком (см. пример такой конфигурации в статье Serial_Console).
  • Запустите приложение NetInstall на ноутбуке.
  • Нажмите кнопку Net booting, поставьте галочку Boot Server enabled и введите корректный IP-адрес (из той же подсети, что и IP-адрес ноутбука, например 10.1.1.5), его NetInstall назначит устройству RouterBOARD для связи с ноутбуком. Затем следуйте нижеследующим инструкциям (выбирайте нужную в зависимости от того, имеет ли Ваше устройство MikroTik COM-порт).

Настройка без COM-порта

Чтобы загрузить RouterBOARD без COM-порта через сеть, используйте кнопку сброса. Подробные инструкции для этого см. в руководстве пользователя Вашего RouterBOARD (routerboard.com -> выберите нужную модель -> скачайте руководство пользователя слева вверху страницы), обычно для этого нужно нажать кнопку сброса, НЕ отпуская её подать питание на устройство и держать ещё примерно 15-20 секунд (если у Вашей модели есть LCD-экран, то на нём должна появиться надпись Netinstall).

К примеру, у RB711U-2HnD кнопка сброса (RES на лицевой панели) имеет две функции - сброс конфигурации RouterOS и загрузка по сети (Etherboot): подключите кабель от ПК с NetInstall в порт ether1 и долго удерживайте эту кнопку во время загрузки, пока световые индикаторы не погаснут, затем отпустите, и RouterBOARD будет искать серверы NetInstall (не забудьте перед этим настроить программу Netinstall, как описано выше).

Также, Etherboot может быть настроен из-под RouterOS в самом роутере, если к ней есть доступ, для этого введите в терминал команду

system routerboard settings set boot-device=try-ethernet-once-then-nand

Настройка с COM-портом

Для доступа к конфигурации BIOS роутера, перезагрузите RouterBOARD во время режима наблюдения в serial-консоли. В ней вы увидите строку “Press any key within 2 seconds to enter setup”, указывающую, что в течении двух секунд нажатие любой клавиши даст Вам доступ к опциям настройки BIOS роутера.

После нажатия клавиши Вы увидите следующий список доступных настроек BIOS:

What do you want to configure?
  d - boot delay
  k - boot key
  s - serial console
  l - debug level
  o - boot device
  b - beep on boot
  v - vga to serial
  t - ata translation
  p - memory settings
  m - memory test
  u - cpu mode
  f - pci back-off
  r - reset configuration
  g - bios upgrade through serial port
  c - bios license information
  x - exit setup

Для настройки загрузочного устройства нажмите клавишу o. Затем нажмите e, чтобы RouterBOARD загружался по сети:

Select boot device:
* i - IDE
  e - Etherboot
  1 - Etherboot (timeout 15s), IDE
  2 - Etherboot (timeout  1m), IDE
  3 - Etherboot (timeout  5m), IDE
  4 - Etherboot (timeout 30m), IDE
  5 - IDE, try Etherboot first on next boot (15s)
  6 - IDE, try Etherboot first on next boot (1m)
  7 - IDE, try Etherboot first on next boot (5m)
  8 - IDE, try Etherboot first on next boot (30m)

Вы вернётесь в начальное меню. Нажмите клавишу x для выхода.

Удостоверьтесь, что протоколом загрузки является bootp.

Установка

С помощью serial-консоли наблюдайте за перезагрузкой роутера, она покажет, что RouterBOARD попытается загрузиться с помощью программы NetInstall. NetInstall назначит роутеру IP-адрес, который Вы ввели на шаге 4 (10.1.1.5/24), и он станет готов к установке ПО. MAC-адрес роутера должен появиться в списке Routers/Drivers в окне программы NetInstall (если не появился, то попробуйте ещё раз, например попробуйте дольше удерживать кнопку сброса, а также запустите программу Netinstall с правами администратора и отключите сетевой экран).

2 (9).png

Кликните на строку роутера, чтобы изменить параметры установки, связанные с этим устройством.

3 (7).png

!!! Для большинства случаев переустановки RouterOS на устройства RouterBOARD Вам будет необходимо установить ТОЛЬКО следующий параметр:

Нажмите клавишу Browse... и в появившемся окне перейдите в папку с .npk-файлом(ами), который(е) Вы хотите установить на RouterBOARD.

4 (4).png

Отметьте галочкой нужные пакеты в списке.

После завершения настройки параметров установки, нажмите кнопку Install для начала установки RouterOS.

5 (2).png

Когда установка будет закончена, нажмите Enter в консоли или кнопку Reboot в программе NetInstall.

6 (1).png

Возвращаем прежние настройки (если Вы раньше использовали Serial-подключение)

  • Настраиваем RouterBOARD на загрузку со встроенной памяти (см. начало пункта 4):

7 (3).png

  • Перезагружаем устройство.

Дополнительно: сброс пароля RouterOS

NetInstall может также использоваться для сброса пароля в RouterOS устройства путём стирания всех конфигурационных настроек из RouterBOARD. Для этого нужно повторить все вышеперечисленные шаги пункта 4, но на этапе настройки параметров установки RouterOS снять галочку "Keep Old Configuration" и продолжить как обычно.

8 (1).png

Как очистить address-list

/ip firewall address-list remove [/ip firewall address-list find list="namelist"]

Смена MAC адреса

user $ /interface ethernet set eth1 mac-address XX:XX:XX:XX:XX:XX

Подключение внешней антенны к MikroTik RB751

С обратной стороны корпуса MikroTik RB751G или RB751U находится разъем MMCX (мама) для подключения внешней антенны.

Разъем для подключения внешней антенны к MikroTik RB751

Чтобы подключить внешнюю антенну к этому разъему вам понадобится переходник (пигтейл), у которого с одной стороны будет разъем MMCX (папа), а с другой разъем для вашей антенны.

Разъемы MMCX (папа) бывают следующих видов:

прямой разъем MMCX (папа); Г-образный разъем MMCX (папа).

Как увеличить размер лога

Переходим в подменю /system logging action и ставим значение для disk-lines-per-file